Skip to end of metadata
Go to start of metadata

Upgrade required when upgrading 1.4.1 to 1.4.2

To upgrade you will need to apply the update_v1.4.1_to_v1.4.2.mysql.sql file to you database. In the WAR file distribution it's in the 

sql/mysql/upgrade directory. The standalone distribution does not contain the upgrade file, download it at from this location

You can either apply this file using the graphical MySQL workbench or using the command line tool.

Apply using MySQL workbench

  1. In the MySQL workbench, go to file -> Open SQL Script. 
  2. Navigate to sql/mysql/upgrade folder in the eHour install folder and open the update_v1.4.1_to_v1.4.2.mysql.sql script
  3. When the script is loaded, highlight the ehour schema in the Navigator under Schemas.
  4. In the main navigation, go to Query and click "Execute (all or selection)"

Apply using command line

Apply the sql/mysql/upgrade/update_v1.4.1_to_v1.4.2.mysql.sql by running the following command - replacing <user> with your database user:


Upgrade required when upgrading 1.3 to 1.4.1

The new manager role and the exclusion of users in a timesheet lock require a few database changes. 

To upgrade you will need to apply the update_v1.3_to_v1.4.mysql.sql file to you database. In the WAR file distribution it's in the 

sql/mysql/upgrade directory. The standalone distribution does not contain the upgrade file, download it at from this location

You can either apply this file using the graphical MySQL workbench or using the command line tool.

Apply using MySQL workbench

  1. In the MySQL workbench, go to file -> Open SQL Script. 
  2. Navigate to sql/mysql/upgrade folder in the eHour install folder and open the update_v1.3_to_v1.4.mysql.sql script
  3. When the script is loaded, highlight the ehour schema in the Navigator under Schemas.
  4. In the main navigation, go to Query and click "Execute (all or selection)"

Apply using command line

Apply the sql/mysql/upgrade/update_v1.3_to_v1.4.mysql.sql by running the following command - replacing <user> with your database user:


Upgrade required when upgrading to 1.3

The new locking functionality requires a few new database tables to be created. To upgrade you will need to apply the update_v0.8.4_to_v1.3.mysql.sql file which can be found in

the sql/mysql/upgrade directory. You can either apply this file using the graphical MySQL workbench or using the command line tool.

Apply using MySQL workbench

  1. In the MySQL workbench, go to file -> Open SQL Script. 
  2. Navigate to sql/mysql/upgrade folder in the eHour install folder and open the update_v0.8.4_to_v1.3.mysql.sql script
  3. When the script is loaded, highlight the ehour schema in the Navigator under Schemas.
  4. In the main navigation, go to Query and click "Execute (all or selection)"

Apply using command line

Apply the sql/mysql/upgrade/update_v0.8.4_to_v1.3.mysql.sql by running the following command - replacing <user> with your database user:

Icon

The standalone distribution does not contain update_v0.8.4_to_v1.3.mysql.sql. The file is available at this location

  • No labels